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1 Figures

1.1 Graphics Dialog

To insert an image into your document, place the cursor at the text position you want and

. . - . . .

click on the toolbar icon or use the menu Insert> Graphics. Then a dialog will appear
to choose the file to load. The image will appear in the output exactly at the position where
it is in the text.

The graphics dialog can be called at any time by right-clicking on an image. This dialog
has three tabs:

Graphics Here you can choose an image file and adjust its appearance in the output. The
available units for the image size are explained in appendix A.
You can rotate images counter-clockwise by setting a rotation angle and a rotation
origin. The image will also be rotated inside LyX.
Images can be scaled by using a percentage value or by setting the width and height
explicitly. If you set only the width or only the height, the other size will be de-
termined automatically. If you set both, then the image will be transformed to the
given size, possibly distorting it. To prevent the image from distortion, use the op-
tion Maintain aspect ratio. The image will then be scaled so that its width and height
don’t exceed the specified dimensions.
Images can be opened in a program of your choice when pressing the Edit button.
The program can be set for every image format in the file format settings in LyX’s
preferences.

Clipping Alternatively to the usage of scaling units it is possible to set image coordi-
nates to adjust the height and width of the image in the output. The coordinates can
also be calculated automatically by pressing the button Get from File. The option
Clip to bounding box will only print the image region within the given coordinates.
Normally you don’t need to take care about image coordinates and can ignore this
tab.

Extra options In this tab you can modify the appearance of the image within LyX and
set the image to be a subfigure of a figure float with an own caption. Subfigures are
explained in section 1.2.

I&TEX experts can also specify on this tab additional IATEX options.
The option Draft mode makes the image appear in the output only as a frame with
the size of the image.



1 Figures

The Don’t unzip on export option only affects zipped EPS-graphics, e. g. x.eps.gz.
When the option is used the images will not be unzipped on export, since IXIEX can
handle them as they are.

Zipped EPS-graphics are useful to save disk space when you choose PostScript as
output format, see appendix B.2. To zip EPS-graphics, use the following commands
in a UNIX-shell or a Windows console:

gzip x.eps

zgrep % % Bounding x.eps.gz > x.eps.bb

The second command creates the bounding box file “x.eps.bb” that is needed by
I&TEX for zipped graphics.

This is an example image in EPS format! within a separate, horizontally centered para-
graph:

This is the same image like the one above but in draft mode:

3_home_luca_lyx_test_lyx-devel_ lib_doc_clipart_mobius.pdf

1.2 Figure Floats

For general explanations about floats, have a look at section 3.1.

The toolbar button and the menu Insert> Float> Figure inserts a float with a caption
that has the label “Figure #:” (# is the actual number). You can insert the image above the
caption, like in Figure 1.1 or below the caption, like in Figure 1.2. More about the caption
placement is described in section 3.8.



1.2 Figure Floats

Figure 1.1: A severely distorted platypus in a float.

Figure 1.2: M.C. Escher on acid.
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(a) Undefinable structure (b) Platypus

Figure 1.3: Two distorted images.

Figure 1.1 and 1.2 are examples of referenced figures. Figures can be referenced in the text
by referencing their label. To do this insert a label in the caption using the menu Insertr>

Label or the toolbar button @ You can now refer to the label using the menu Insert>

Cross reference or the toolbar button tﬂ It is important to use references to floats, rather
than using vague references like “the figure above”, because as IATEX will reposition the
floats in the final document, it might not be “above” at all.

Referencing is explained in detail in section 3.4.

Normally only one image is inserted to a figure float, but sometimes you might want to
use two images with separate subcaptions. This can be set in the tab Extra options of the
graphics dialog. Choose there the option Subfigure and enter the subcaption for the image
in the caption field. Note that only the main caption of the float is added to the List of
Figures.

Referencing subfigures is explained in section 3.4.2.

Figure 1.3 is an example of a figure float with two images set side by side. You can also
set the images one below the other.

1.3 Image Formats

You can insert images in any known file format. But as explained in appendix B, every
output document format allows only a few image formats. LyX uses therefore the program
Imagemagick in the background to convert the images to the right format. To increase

Tmage formats are explained in section 1.3.



1.3 Image Formats

your work flow by avoiding these conversions in the background, you can use only the
image formats that can directly be embedded in the output file format. The output file
formats are explained in appendix B.

Similar to fonts there are two types of image formats:

Bitmap images consist of pixel values, often in a compressed form. They are therefore
not fully scalable and look pixeled in large zooms. Well-known bitmap image for-
mats are “Graphics Interchange Format” (GIF, file extension “.gif”), “Portable
Network Graphics” (PNG, file extension “. png”), and “Joint Photographic Experts
Group” (JPG, file extension “. jpg” or “. Jjpeg”).

Vector images consist of vectors and can therefore be scaled to any size without data

loss. The scaling ability is necessary if you want to create presentations, because
presentations are always scaled by the video projector. Scaling is also useful for on-
line documents to let the user zoom into diagrams.
Well-known scalable image formats are “Scalable Vector Graphics” (SVG, file exten-
sion “. svg”), “Encapsulated PostScript” (EPS, file extension “. eps”), “Portable
Document Format” (PDF, file extension *“.pdf”), and “Windows Metafile” (WME,
file extension “.wmf”). We wrote “can be”, because you can convert any bitmap
image to a PDF or EPS-image and the result will still be a bitmap image. In this
cases only a header with the image properties is added to the original image®. The
PDF-files generated by Adobe Photoshop are for example bitmap images.

Normally it is not possible to convert a bitmap image into a scalable one, only vice versa.
Only the image formats PDF and EPS can directly be embedded to PDF and PostScript out-
put files, respectively. SVG and WMF-images are recalculated to bitmaps when the output
file is generated because there is currently no adequate WMF/SVG—PDF/EPS converter
available.

%In the case of PDF, the original image is additionally compressed.
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2 Tables

2.1 Introduction

EFE

You can insert a table using either the toolbar button ™+ or the menu Insert> Table. The
toolbar button offers you a graphical selection: Move the mouse to set the column/row
number of the table that should be created and then press a mouse button. When you use
the menu to create a table, a dialog will appear, asking you for the number of rows and
columns.

The default table has lines around any cell and the first row appears separated from the rest
of the table. This separation occurs due to a double line: The cells of the first row have a
line below them and the cells of the second row have a line above them. Here is an example
table:

[ [1[2[3]
A
c

2.2 Table Dialog

You can alter a table by clicking on it with the right mouse button, which brings up the table
dialog. Here you can adjust the settings of that cell and row/column respectively where the
cursor is currently placed. Most of the dialog options also work on selections. This means
if you select more cells, columns or rows, the action is done for the whole selection. Note
that there is a difference between selecting the contents of the cell, and the cell itself. You
can alter tables with the following tabs of the table dialog:

Table Settings Here you can set the horizontal alignment and the width of the current
column. When you have set a width you can also adjust the vertical alignment of
the current row. A given width will allow the cell to have line breaks and multiple
paragraphs of text, see section 2.8.1. If you set no width, the column is as wide as
their widest cell content is.

Furthermore, you can mark one or multiple cells of one row as a multicolumn cell,
see section 2.8.2.



2 Tables

The rotate check boxes rotates the current cell, a selection, or the whole table counter-
clockwise by 90°. The rotation is not shown within LyX, only in the output.

Note: Not all DVI-viewers are able to display rotations.

It is also possible to enter a IATEX-argument which is needed for special table for-
mattings, see section 2.8.2.2 and 2.11.

Borders In this tab you can add and delete border lines for the current row/column.
Using the style option Formal will convert the table to a formal table as described in
section 2.9.

You can also add here space to table rows as decribed in section 2.12.1.

Longtable This tab is to make a table a so called “longtable” that can run over several
pages. Section 2.6 and 2.7 describe the longtable features in detail.

When the table toolbar is opened, you can move the cursor with the arrow keys from cell
to cell and the property of the current cell will immediately be displayed in the dialog.

2.3 Table Toolbar

The table toolbar is an alternative to the table dialog to be able to alter tables faster. It
should normally appear at the bottom of LyX’s main window when the cursor is inside a
table. You can alternatively switch it on to appear always, by right-clicking in LyX’s main
menu bar.

The toolbar has the following icons:

E adds a row below the current cell or selection
ﬁ:l, adds a column right beside the current cell or selection
Ex deletes the current row or selection
m .
* deletes the current column or selection

adds a line at the top of the current cell / row or of a selection

e adds a line at the bottom of the current cell / row or of a selection
I adds a line at the left side of the current cell / row or of a selection

. adds a line at the right side of the current cell / row or of a selection

D adds lines around the current or selected cells - if the current cell no multicol-
umn this also affects the current row and column
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2.4 Edit Table Menu

deletes all lines of the current or selected cells - if the current cell no multicol-
umn this also affects the current row and column

left-aligns the content of the current cell / column

centers the content of the current cell / column horizontally
right-aligns the content of the current cell / column

aligns the content of the current cell vertically to the top
centers the content of the current cell vertically

aligns the content of the current cell vertically to the bottom
rotates the current cell or selection counter-clockwise by 90°
rotates the whole table counter-clockwise by 90°

sets the current cell or selection as a multicolumn

Note: For the output the vertical alignment of the first cell in a row is used for all following
cells in the row.

2.4 Edit Table Menu

Additionally to the table dialog and toolbar, the menu Edit>Table allows you to add and
delete border lines for the current row/column and to set the current selection as multicol-
umn. The menu is only available when the cursor is inside a table.

2.5 Table Floats

For general explanations about floats, have a look at section 3.1.

Table 2.1: A table float.

1| 2 3
Joe Mary Ted
[ede| |40 1e1=2

c d




2 Tables

Table floats can be inserted using the menu Insert> Float> Table or the toolbar button %

The float appears as a collapsible box with a caption that has the label “Table #:” (# is the
actual table number). You can insert tables to the float above or below the caption.

Table 2.1 is an example table within a table float.

Having the caption above the table is the common rule that is unfortunately not supported
in IATEX’s standard classes. That means if you are using the document classes article,
book, letter, or report there will be no space between the caption and the table. To insert
the needed space, add the following option to the load command of the I&TEX-package
caption in your document preamble':

tableposition=top
The package caption, which is described in section 3.7, is used to adjust the caption format.

Tables can be cross-referenced in the text by referencing their label. To do this insert a

label in the caption using the menu Insert> Label or the toolbar button @ You can now

refer to the label using the menu Insert> Cross reference or the toolbar button tﬂ
Referencing is explained in detail in section 3.4.

2.6 Longtables

If the table is too long to fit on one page, you can use the option Use long table in the tab
Longtable of the table dialog to split the table automatically over more pages. Doing this
enables some check boxes and you can now define:

Header: The current row and all rows above, that don’t have any special options defined,
are defined to be the header rows of all pages of the longtable; except for the first
page, if First header is defined. This therefore called the main header.

First header: The current row and all rows above, that don’t have any special options
defined, are defined to be the header rows of the first page of the longtable.

Footer: The current row and all rows below, that don’t have any special options defined,
are defined to be the footer rows of all pages of the longtable; except for the last
page, if Last footer is defined.

Last footer: The current row and all rows below, that don’t have any special options de-
fined, are defined to be the footer rows of the last page of the longtable.

You can also specify a row where the table is splitted. If you set more than one option in
the same table row, you should be aware of the fact that only the first one is used in the
given table row. The others will then be defined as empty. In this context, first means first
in this order: Header, First header, Footer, Last footer. See the following longtable to see
how it works:

IFor more information have a look at section 3.8.

10



Example Phone List (ignore the names)

NAME TEL.
Annovi Silvia 111
Bertoli Stefano 111
Bozzi Walter 111
Cachia Maria 111
Cachia Maurizio 111
Cinquemani Giusi 111
Colin Bernard 111
Concli Gianfranco 111
Dal Bosco Carolina 111
Dalpiaz Annamaria 111
Feliciello Domenico 111
Focarelli Paola 111
Galletti Oreste 111
Gasparini Franca 111
Rizzardi Paola 111
Lassini Giancarlo 111
Malfatti Luciano 111
Malfatti Valeriano 111
Meneguzzo Roberto 111
Mezzadra Roberto 111
Pirpamer Erich 111
Pochiesa Paolo 111, 222
Radina Claudio 111
Stuffer Oskar 111
Tacchelli Ugo 111
Tezzele Margit 111
Unterkalmsteiner Frieda 111
Vieider Hilde 111
Vigna Jirgen 111
Weber Maurizio 111
Winkler Franz 111
Annovi Silvia 555
Bertoli Stefano 555
Bozzi Walter 555

continued on next page

2.6 Longtables

11



2 Tables

Example Phone List
NAME TEL.

Cachia Maria 555
Cachia Maurizio 555
Cinquemani Giusi 555
Colin Bernard 555
Concli Gianfranco 555
Dal Bosco Carolina 555
Dalpiaz Annamaria 555
Feliciello Domenico 555
Focarelli Paola 555
Galletti Oreste 555
Gasparini Franca 555
Rizzardi Paola 555
Lassini Giancarlo 555
Malfatti Luciano 555
Malfatti Valeriano 555
Meneguzzo Roberto 555
Mezzadra Roberto 555
Pirpamer Erich 555
Pochiesa Paolo 555, 222
Radina Claudio 555
Stuffer Oskar 555
Tacchelli Ugo 555
Tezzele Margit 555
Unterkalmsteiner Frieda 555
Vieider Hilde 555
Vigna Jiirgen 999
Weber Maurizio 555
Winkler Franz 555

end

2.6.1 Footnotes in Longtables

Footnotes can be inserted to every longtable cell. They appear at the bottom of the page
where the table cell with the footnote appears. Table 2.7 has for example a footnote.

12



2.6 Longtables

2.6.2 Longtable Alighment

Longtables are by default centered. In contrary to the alignment of the table columns and
row, the table alignment can currently not be changed in the table dialog. To change the
alignment of longtables you have to change the value of the lengths \LTleft and \LLTright
by inserting this line as TEX-Code before the corresponding longtable:

\setlength{\LTleft}{value}

Where the value can have any of the units listed in Table A.1. \LTleft controls the hori-
zontal distance from the left page border to the longtable, \LTright the distance from the
right side. The default value for both lengths is \fill, which is in this case the same as an
horizontal fill in LyX.

The following longtable was left-aligned by setting \LLTleft to O pt.

1 2 3 4 5
asd | s S s |asd
asd | s S s |asd
asd | s S s | asd
asd | asd | asd | asd | asd

2.6.3 Longtable Captions

A longtable cannot be put into a table float because floats can only be on one page but the
caption environment of floats can also be used for longtables.

As LyX does not yet fully support captions in longtables, a hack is needed to create them:

1. Create a longtable.
2. Mark the first row and disable its upper line.

3. Insert a caption via the menu Insert> Caption into the first table cell.
You can also add a short title for the caption.

4. Insert a “\%” as TgX-Code behind the caption.

A short title that will appear in the LOT instead of the full title. The W% behind the caption
omits the vertical lines between the following cells in the row. The first table row is now
only a dummy row for the caption, the actual table starts with the second row.

Here is a short longtable to see how it works:

Table 2.3: Longtable with caption

1 2 3 4 5
asd S S S asd

13



2 Tables

asd | s S S asd

asd | s S S asd

asd | asd | asd | asd | asd

Note: The table number is increased for every longtable, also if you didn’t set a caption
for it. For this reason you could have the case that e.g. Table 2.4 follows on Table 2.1 in
the list of tables if there are two longtables without captions. To avoid this you can add the
following command in TgX-Code behind every longtable without a caption:

\addtocounter{table}{-1}

Note: If you are using the IXTgX-package hyperref to link cross-references, the link to a
longtable caption will always point to the beginning of the document.

14



2.6 Longtables

2.6.3.1 References to Longtables

Table 2.4: Referenced longtable

1 2 3 4 5
asd | s S s | asd
asd | s S s | asd
asd | s S s | asd
asd | sad | asd | asd | asd

To reference a longtable, insert a label into the caption. Note that you have to add the label
prefix “fab:* manually in the label field.

This is a reference to Table 2.4.

The caption layout can be set together with all other caption of your document using the
IATEX-package caption, see section 3.7.

2.6.3.2 Caption Width

The maximal width of of caption lines is defined by the length \LLTcapwidth. Its default
value is 4in. To change it add the following command to your document preamble or as
TgX-Code into your document before the longtable that should be affected

\setlength{\LTcapwidth}{width}
where the width could have one of the units listed in appendix A.
The following tables show the difference:

Table 2.5: long full title with default width long full title with default width long full title
with default width

asd | s S S asd
asd | s S s | asd
asd | s S s | asd

asd | sad | asd | asd | asd

15



2 Tables

Table 2.6: long full title with
width set to 5cm long full
title with width set to 5cm
long full title with width set
to Scm

1 2 3 4 5

asd | s S s | asd
asd | s S S asd
asd | s S S asd

asd | sad | asd | asd | asd

Note: When the I&TEX-package caption is used, as in this document, the full page width is
used for the caption when you use the default value of 4 in for \LTcapwidth. To get in this
case exactly a 4in wide caption, you can either use a value slightly different from 4.0 in,
e.g. 3.991n, or the I&T[gX-command \captionsetup{width=value} that is provided by the
caption-package.

2.6.3.3 Different Captions for Table Pages

When the other captions should differ from the one of the first table page, insert a caption
with a non-empty short title in a dummy caption row marked as first header. The caption
used for the other table pages is inserted as caption without a short title in a dummy caption
row that is marked as main header. When this caption shouldn’t include the table number,
use the command

\caption*{caption text}

instead of LyX’s caption box. The label to reference the table is inserted into the caption
of the first header. Table 2.7 is an example for a longtable with different heading where the
second caption doesn’t include the table number.

Table 2.7: Example Phone List

Example Phone List (ignore the names)
NAME TEL.
Annovi Silvia 111
Bertoli Stefano 111
Bozzi Walter 111
Cachia Maria 111
Cachia Maurizio 111

continued on next page

16



Continued Example Phone List

Example Phone List
TEL.
Cinquemani Giusi 111
Colin Bernard 111
Concli Gianfranco 111
Dal Bosco Carolina 111
Dalpiaz Annamaria 111
Feliciello Domenico 111
Focarelli Paola 111
Galletti Oreste 111
Gasparini Franca 111
Rizzardi? Paola 111
Lassini Giancarlo 111
Malfatti Luciano 111
Malfatti Valeriano 111
Meneguzzo Roberto 111
Mezzadra Roberto 111
Pirpamer Erich 111
Pochiesa Paolo 111,222
Radina Claudio 111
Stuffer Oskar 111
Tacchelli Ugo 111
Tezzele Margit 111
Unterkalmsteiner Frieda 111
Vieider Hilde 111
Vigna Jiirgen 111
Weber Maurizio 111
Winkler Franz 111
Annovi Silvia 555
Bertoli Stefano 555
Bozzi Walter 555
Cachia Maria 555
Cachia Maurizio 555

2.6 Longtables

continued on next page

ZExample footnote

17



2 Tables

Continued Example Phone List

Example Phone List
NAME TEL.
Cinquemani Giusi 555
Colin Bernard 555
Concli Gianfranco 555
Dal Bosco Carolina 555
Dalpiaz Annamaria 555
Feliciello Domenico 555
Focarelli Paola 555
Galletti Oreste 555
Gasparini Franca 555
Rizzardi Paola 555
Lassini Giancarlo 555
Malfatti Luciano 555
Malfatti Valeriano 555
Meneguzzo Roberto 555
Mezzadra Roberto 555

2.7 Special Longtable Issues

2.7.1 Longtable Calculation

IATEX calculates the height of table pages and their page breaks using so called chunks.
Chunks are pieces of the tables that are at once in I£I[EX’s memory. The default value is
historically set to only 20 table rows. If you are using longtables with many pages this may
slow down the creation of your document. You can safely increase the chunk size to values
of 100-1000 by adding this command line to your document preamble:

\setcounter{LTchunksize}{100}

2.7.2 Floats and Longtables

There might be problems when a float appears on the same page where a longtable starts.
To avoid such situation, add the command \clearpage as TgX-Code before your longtable.

18




2.7 Special Longtable Issues

2.7.3 Forced Page Breaks

By default tables are only broken between rows. If you have a cell with multiples lines and
want to have a page break within the cell, insert the new line command “\\” as TgX-Code at
this point of the cell where it should be broken. Before the \\ command you have to insert
in TgX-Code so many “&” characters like the number of the following table columns. The
& is the character to separate table cells. Write in TgX-Code after each & the content of
the corresponding following cell and delete the content of these cells.

Behind the the \\ command, insert so many & characters like the number of table columns
before the current column. In Table 2.8 the cell that should be broken is in the second
column followed by another column. Therefore the following command was inserted in
the cell as TgX-Code behind “Castelchiodato,”:

& 111\
&

The “111” in the third columns of the row was deleted. If your footer row of the longtable
has for a certain reason no upper line but you would have a horizontal line where the cell
is broken, use this command instead:

& 111\
\hline &

‘When the cell to be broken is in the last column, the command
\setlength{\parfillskip }{Opt}

must be inserted as TEX-Code at the beginning of the cell. This assures that the part of the
cell that will be displayed on the new page appears with the full width.

Table 2.8: Table with forced page break in table cell

Example Phone List (ignore the names)
NAME TEL.
Annovi Silvia 111
Bertoli Stefano 111
Bozzi Walter 111
Cachia Maria 111
Cachia Maurizio 111
Cinquemani Giusi 111
Colin Bernard 111
Concli Gianfranco 111
Dal Bosco Carolina 111
Dalpiaz Annamaria 111

continued on next page
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20

Continued table with forced page break in table cell

Example Phone List
NAME TEL.

Feliciello Domenico 111
Focarelli Paola 111
Galletti Oreste 111
Gasparini Franca 111
Lassini Giancarlo 111
Malfatti Luciano 111
Malfatti Valeriano 111
Meneguzzo Roberto 111
Mezzadra Roberto 111
Pirpamer Erich 111
Pochiesa Paolo 111,222
Radina Claudio 111
Rizzardi Paolo, 11. Fiirst 111

von

Montecompatri,

11. Fiirst von
Sulmona und
Vivaro, 10. Fiirst
von Rossano, 5.
Herzog von
Canemorte, 11.
Herzog von
Palombara, 5.
Herzog von
Castelchiodato,

continued on next page




Continued table with forced page break in table cell

2.7 Special Longtable Issues

Example Phone List

NAME

TEL.

Stuffer

Tacchelli

Tezzele
Unterkalmsteiner
Vieider

Vigna

Weber

Winkler

11. Herzog von
Poggionativo, 11.
Markis von
Mentana, Norma,
Civitella, Pratica,
Moricone und
Percille, 11. Graf
von Valinfreda,
11. Baron von
Cropalati, 11.
Herr von Scarpa,
Edelmann von
Rom, Patrizier
von Venedig,
Neapel und
Genua

Oskar
Ugo
Margit
Frieda
Hilde
Jirgen
Maurizio
Franz

111
111
111
111
111
111
111
111
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2.8 Multiple Lines Columns and Rows
2.8.1 Multiple Lines in Table Cells

Table 2.9: Table with multiple lines in cells

mqltlple bl e
lines

d e | f

g h|i

Adjusting a fixed width for a column, enables to enter text as a paragraph with multiple
lines and hyphenations.

To produce Table 2.9, create a 3x3 table, mark the first cell and right-click on it. In the
appearing table dialog we set a cell width of 2.5 cm and choose centered for the vertical
and horizontal alignment. The vertical alignment is used for all cells of the row. As our
text is smaller than than 2.5 cm, only one line will appear. To get two lines, we add a line
break with the command

\linebreak

in TgX-Code. If the text is wider than the set cell width it will automatically be broken to
several lines.

If you have a long word in a cell with a fixed width, it cannot be hyphenated by IATEX if it
is the first entry. Therefore you need to insert something, to make the word not being the
first entry: Add the command

\hspace{Opt}

in TeX-Code before the word. As the space is zero, it doesn’t change the output. Table 2.10
shows the effect.

Table 2.10: Table with and without hyphenation

verylongtable- b
verylongtablecelltvord cellword c
d e | f q N
£ hjt g hli
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2.8 Multiple Lines Columns and Rows

Table 2.11: Table with centered multicolumn text above two columns that have exactly
half the width of the multicolumn cell

multiple lines c
multicolumn
d e f
g h 1

2.8.2 Multicolumns
2.8.2.1 Multicolumn Basics

To span a cell over multiple columns, mark as much cells within a line that should be

one spanned cell and use either the table-toolbar button @, or the menu Edit> Tabler>
Multicolumn, or right click on the marked cells and choose multicolumn in the appearing
table dialog under the tab Table Settings.

Multicolumns have there own cell settings. That means changing cell borders, cell align-
ment, and the width only affects the multicolumn. Here is an example table with a multi-
column cell in the first row and one in the last row without the upper border:

| abc | def ghi | jkI |
A|B|C|D
1|23 ]4

2.8.2.2 Multicolumn Calculations

LyX supports multicolumns directly, but we have to take notice of the cell width of the
columns spanned by the multicolumn cell.

To create for example Table 2.11, mark the first two cells in the first row of a 3x3 table and
right-click on them. Now choose for this cell multicolumn, centered alignment and a width
of 2.5 cm in the table dialog. The spanned columns should have exactly half the width of
the multicolumn cell, so that you would adjust a width of 1.25 cm for the first column. The
second column has then automatically a width of 1.25 cm (multicolumn width - width of
first column). This was done for Table 2.12.

You can see that the first column has not the half width of the multicolumn cell, it is a bit
bigger. The reason is that the given width of a cell W, is not its total width Wy because a
cell is always a bit larger than its given width. Appendix (C) explains it in detail.

The needed given width Wy, when n columns are spanned can be calculated, so that each
column has a total width of Wiotmulticolumn/7:

Wen = (Wemuliicolumn + (1 —12) - (12.4pt)) /n 2.1)
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Table 2.12: Table where the spanned table columns have not exactly half the width of the
multicolumn cell

multiple lines | ¢
multicolumn
d e f
g h 1

In our case we have n = 2, Wy muiticolumn = 2.5 ¢cm and the default values for the lengths, so
that equation 2.1 becomes

We2 =1.25cm—6.2pt 2.2)

To enable calculations in ISTEX, the IATEX-package calc must be loaded with the document
preamble line

\usepackage{calc}

LyX does not allow to calculate lengths in the width-field of the table dialog. Therefore
you have to format the column by inserting a I&TgX-argument in the dialog. Here is an
overview about the arguments:

» p{width} creates cell with a fixed width, its text is vertically top-aligned
» m{width} creates cell with a fixed width, its text is vertically centered

* b{width} creates cell with a fixed width, its text is vertically bottom-aligned

By entering a IATEX-argument, all cell settings set in the table dialog are overwritten.
Note: Due to a bug, LyX shows the overwritten settings anyway.

As the text should be horizontally centered, the command \centering is added. You can
now enter the following IATEX-argument for the first spanned column:

>{\centering}m{1.25cm-6.2pt}

The command >{ } means, that the commands inside the braces are applied before the cell
is created.

Although we have chosen centered alignment for the text of the multicolumn cell, it is still
left aligned. This is because LyX only applies the alignment to single columns. So we have
to use for the multicolumn the I£TEX-argument

>{\centering}m{2.5cm}

2.8.3 Multirows

In contrary to multicolumns multirows are not yet supported by LyX so a bit of TgX-Code
needs to be used. To use multirows load the IATgX-package multirow in your document
preamble with the command
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2.9 Formal Tables

\usepackage{multirow}
Multirows are created with the command
\multirow{number of rows}{cell width}{cell entry}

To create the following table:

a b

multirow entry

create a 3x3 table. To get rid of the line above the last cell in the first column, the cell is
marked as multicolumn and the upper border is unset. The multirow is now created in the
second row of the first column by inserting there the command

\multirow{2}{2.5cm}{

as TgX-Code. According to the command parameters the multirow spans now two rows
and has a width of 2.5 cm. The content of the multirow cell follows outside the TEX-Code
box and the command is finished with a right brace } in another TgX-Code-box behind the
text.

\multirow left-aligns its content by default. To override the default, renew the command
\multirowsetup with the command

\renewcommand{\multirowsetup }{\centering}

in TEX-Code in the document preamble. Then all entries of multirow cells in the document
are centered. If centering is only needed for several tables, you can renew the command
in an TgX-Code box just before the table instead of the preamble. If the text should be
right-aligned, replace \centering by \raggedleft. To return to left-alignment \raggedright
is used.

2.9 Formal Tables

Tables are often typeset in books similar to Table 2.13. This kind of tables is called “for-
mal”. To make a table a formal table use the option Formal in the Borders tab of the table
dialog.

Spaces to table rows can be added using the Borders tab of the table dialog as described in
section 2.12.1.

In contrary to normal tables, formal tables have no vertical table lines. The horizontal table
lines can be set like for normal tables but they appear with different width in the output:
The first and the last table line have a default width of 0.08 em while the other lines have a
default width of 0.05 em.
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Table 2.13: Example booktabs-table

System Medipix 1 Medipix 2
Detector thickness [um] 300 300 700
Edge angle [°] 3.55 271 7.99
Spatial resolution [um] 4.26 10.17 10.56
MTF at fiax 0.53 0.37 0.39
LSF-spatial resolution

in um 129.7 52.75 50.78

in % of pixel size 76.3 959 923

The default widths can be changed with the following preamble lines

\let\mytoprule\toprule
\renewcommand{\toprule}{\mytoprule[width]}

This example is for the first line, the so called toprule. If you want to change the width
for the last line, replace toprule by bottomrule. To change the width for the other lines
replace toprule by midrule. You can use all units listed in appendix A to set the width.

Lines that don’t span over all table columns can be created by setting a table line for
multicolumn cells. LyX will then internally use the command \cmidrule to create this line.
Its full scheme is

\cmidrule[width](trim){startcol-endcol}

The options of \cmidrule are are currently not supported by LyX so you have to use TgX-
Code to be able to use them. \cmidrules can manually be created by inserting the command
as TgX-Code as first cell entry of the first cell of a row. The line is then drawn in the output
above the current row.

The default for the width is 0.03 em. Startcol is the number of the column where the line
starts and endcol the column number where the line ends. The endcol always needs to be
specified, also when the line should span only one column. The optional parameter trim
could be either [{trimwidth}, or r{trimwidth} where the trimwidth is also optional. Using
for example the parameter /{2pt} means that the line is trimmed from its left end by 2 pt. If
you don’t specify the trimwidth the lines are trimmed by the default of 0.5 em.

Table 2.13 was created using the commands
\cmidrule(r){2-2\cmidrule(1){3-4}
at the beginning of the in the second row and

\cmidrule(1{10pt}){1-1}
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2.10 Vertical Table Alignment

in the sixth row.

You might want to have overlapping \cmidrules like in Table 2.14. This can be achieved
with the TgX-Code command

\morecmidrules

The command that was used for the second row of Table 2.14 is
\cmidrule(r){2-2}\cmidrule(1){3-4\morecmidrules\cmidrule{2-4}
The command for the sixth row is

\midrule\morecmidrules\cmidrule{3-4}

If you are anyway not satisfied with the border line spacing, you can use the following
command to produce lines that span over all table columns:

\specialrule{width}{space above}{space below}
For more informations about these specialties, we refer to the manual of the IATEX-package
booktabs [4].

Table 2.14: Special booktabs-table

System Medipix 1 Medipix 2

Detector thickness [um] 300 300 700
Edge angle [°] 3.55 271 7.99

Spatial resolution [um] 4.26 10.17 10.56
MTF at fiax 0.53 0.37 0.39

LSF-spatial resolution
in um 129.7 52.75 50.78
in % of pixel size 76.3 959 923

2.10 Vertical Table Alignment

To align tables vertically in a text line the table must be inside a box. The box can then be
vertically aligned as described in section 5.2.

In the following example the tables are inside a minipage® box that has a width of 15 col%:

3Minipages are described in section 5.4.
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* test testia |d| g
fli
a|d|g
etestib|e|h
fli

a|d|g ald|e

ble|h bleln

* test fli test| c | £ |1

As you can see, the content of the first and last table row is not correctly aligned with the
text line where the table is in. To get this alignment, the minipage box must be set into
a raisebox*. In the example above the second table in the first item is aligned using the
TeX-Code-command

\raisebox{0.85\baselineskip }{

before the box. Behind the box the closing brace } is inserted as TgX-Code. For the second
table in the last item the command

\raisebox{-0.32\baselineskip }{
is used.

Note: The alignment of the table row content to the surrounding text line is not exact. The
needed factor of the \raisebox command for this alignment depends on the document font,
the font size, and the table line thickness.

2.11 Colored Tables

2.11.1 Colored Cells

Table 2.15: Table colored without using the package colortbl

b
e
h|i

If you only need colored text, mark the cells and choose a color in the menu Edit>
Text Style. This was used to create Table 2.15. In any other case you have to use the
IATEX -package colortbl.

4Raiseboxes are described in section 5.6.2.
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2.11 Colored Tables

To create colored tables, colortbl must be loaded in the preamble with the line
\usepackage{colortbl}

The color of a column is adjusted with the command

\columncolor{name of color}

inside the command >{ }. More about the command >{} is described in section 2.8.2.2.
The following color names are predefined:

red, green, yellow, blue, cyan, magenta, black and white

You can also define your own color with the command
\definecolor{color name}{color model}{color values}

The color model can be

cmyk: cyan, magenta, yellow, black
rgb: red, green blue
gray gray

and the color values are comma separated numbers between 0 and 1 describing the factor
for the corresponding color of the color model.

You can e. g. define the color "darkgreen" in the preamble with
\definecolor{darkgreen}{cmyk}{0.5, 0, 1, 0.5}

and the color "lightgray" with
\definecolor{lightgray}{gray}{0.8}

Lines are colored with the command

\rowcolor{name of color}

and cells are colored with the command

\cellcolor{name of color}

Both commands are inserted at the beginning of a cell as TgX-Code.

To color characters in the table, mark the cells and use the LyX menu Edit> Text Style. If
a cell contains TgX-Code mark only the characters, otherwise the colored TgX-Code will
cause IATgX-errors.

Note: Not all DVI-viewers are able to display self-defined colors.

To create Table 2.16 do the following: The color of the first column should be darkgreen.
So insert

>{\columncolor{darkgreen}\centering}c

29



2 Tables

as IXTgX-argument for this column. The first row should be blue, therefore the TEX-Code
command

\rowcolow{cyan}

is inserted to the first cell of this row. Note that this overwrites the column color for the first
cell. The last cell of the last row is colored magenta by inserting the TgX-Code command

\cellcolor{magenta}

The characters could now be colored using the menu Edit> Text Style.

Table 2.16: Table colored using the package colortbl

e f

h [

2.11.2 Colored Lines

As described in section 2.12.4, the line thickness for all lines in a table can be adjusted
with the length \arrayrulewidth. It is set to 1.5 pt for all tables of this section.

To color vertical lines for example with green, create the following column format in the
document preamble, according to the description in section 2.12.3:

\newcolumntype{ W }{!{\color{green}\vline}}

For Table 2.17 the I&TgX-argument WeW was used for the last column and We for the
other columns.

If you want to have several colors, define more column formats.

To color horizontal lines for example with red, like in Table 2.18, insert these commands
in TgX-Code before the table or table float:

\let\myHlineC\hline
\renewcommand{\hline}
{\arrayrulecolor{red }\myHlineC\arrayrulecolor{black}}

Table 2.17: Table with colored vertical lines

sd

sd

sd
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2.12 Table Customization

Table 2.18: Table with colored horizontal lines

sd

sd

sd

To return to the default line color black, insert this command in TgX-Code behind the table
or table float:

\renewcommand{\hline }{\myHlineC}

Table 2.19 is an example with colored vertical and horizontal lines.

Table 2.19: Table with colored lines

sd

sd

sd

2.12 Table Customization

2.12.1 Row Spacing

You can add vertical space to table rows in the Borders tab of the table dialog. You find
there three possibilities:

Top of row will add space above the characters of the table row. If the table is a formal
table® LyX will insert as default 0.5 em space. For normal tables the inserted space
will unfortunately destroy the vertical table lines as in the following table:

A

3 mm space top of row
C

So inserting space to the top of row for normal tables is only useful when you don’t
have vertical lines.

Bottom of row will add space below the characters of the table row. If the table is a formal
table LyX will insert as default 0.5 em space, for normal tables the default size is 2 pt.

SFormal tables are explained in section 2.9.
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Between rows adds space between the current and the following row. If the table is a
formal table LyX will insert as default 0.5 em space. For normal tables the inserted
space will unfortunately destroy the vertical table lines as in the following table:

A

| 3 mm space between row |

’ T 3 mm space between row | ‘

So inserting space between rows for normal tables is only useful when you don’t
have vertical lines.

When you want to add extra height to all cells of all tables, you can do this with the
following preamble lines:

\@ifundefined{extrarowheight}
{\usepackage{array}}{}
\setlength{\extrarowheight}{height}

But this has the disadvantage that the cell texts are no longer exactly vertically centered.
(The package array will be loaded automatically by LyX when you use self defined table
formats. To avoid that it is loaded twice the command \@ifundefined is used in the above
command.)

2.12.2 Special Cell Alignment

Sometimes it looks better when the cell entries of a column are aligned with a special
character, e. g. with the decimal separator as in Table 2.20.

Table 2.20: Table cells of a column aligned with the decimal separator.

heading
12.6

0.68
-123.0

This table was created with a 4x2 table. The heading is a centered multicolumn. The first
column is right-aligned and contains the digits before the decimal point and the decimal
point. The second column is left aligned and contains the digits after the decimal point.
To omit the space that is normally between two table columns, use the following IATEX-
argument for the second column:

@{}l

Table 2.21 shows some example alignments. For the alignment with the relation sign, you
must add the second smallest math-space at the beginning of the last column to get the
correct space surrounding the relation sign.
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2.12 Table Customization

Table 2.21: Several table cell alignments.

units exponents ‘ relations
12x24 bottles 10-10717 | (1) &< Y(2)
1024x768 Pixels | 5.78-107 A #Bieq
32x6cm -33.5-10* | sin(a) >sin(B)

There is also the IATEX-package dcolumn that provides table cell alignments. But this
unfortunately treats the cell entries as math and doesn’t allow formulas in table cells: The
first column of Table 2.21 will look with dcolumn like the first column in Table 2.22 and
only with some tricks like the expected. The alignment of the second and third column of
Table 2.21 is not possible with dcolumn.

Table 2.22: Alignments when I&TEX-package dcolumn is used. For all column alignments
tricks have to be used to get the output.

units units units

12x24 bottles 12 x24bottles 12 x 24 bottles
1024 x768 Pixels | 1024 x768 Pixels | 1024 x 768 Pixels

32x6cm 32x6cm 32 x 6cm

2.12.3 Customized Cell/Column Format

Calculating the needed width for spanned columns like in section 2.8.2.2 is very annoying
if you have several tables with multicolumn cells. To make life easier, you can define a
cell/column format in the preamble, so that it can be used in all tables of the document.
The format is defined with the command

\newcolumntype{name of format}[number of arguments]{commands}

The format name may only consist of one letter. The letters b, c, [, m, p and r are predefined
and cannot be used. But all letters are allowed as capitals.

For vertically and horizontally centered multicolumn cells with a fixed width you can de-
fine the cell format

\newcolumntype{M}[1]{>{\centering\hspace{Opt}}m{#1}}

where \hspace{0Opt} avoids the problem of hyphenating the first word, as described in
section 2.8.1. Now you can simply enter

M{width}

as IATgX-argument in the table dialog to create a multicolumn.

For cells spanned by a multicolumn cell, you can define the format
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\newcolumntype{S}[2]{>{\centering\hspace{Opt}}
m{(#1+(2\tabcolsep+\arrayrulewidth)*(1-#2))/#2}}

This format uses equation (2.1) to calculate the needed width so that each spanned cell has
the same width.

You can now enter
S{width of multicolumn cell}{number of spanned columns}

as IATgX-argument of the column.

For colored columns, you can define
\newcolumntype{K}[1]{>{\columncolor{#1}\hspace{Opt}}c}

The “c” at the end creates a column with a flexible width whose text is horizontally cen-
tered. You can now enter

K{color name}

as IATgX-argument.

To create Table 2.23 use the IATgX-arguments
M{2.5cm}

for the first column and the multicolumn,
K{red}

for the the last column, and

S{2.5cm}{2}

for the cells in the second column.

Table 2.23: Table using user-defined table formats

verylongtable- | multiple lines
cellword multicolumn

d e f

h i ]

2.12.4 Line Thickness

The line thickness for all lines in a table can be adjusted with the length \arrayrulewidth.
To set for example a line thickness of 1.5 pt, like in Table 2.24, insert the command

\setlength{\arrayrulewidth}{1.5pt}
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Table 2.24: Table with 1.5 pt thick lines

sd

sd

sd

Table 2.25: Table with 1.5 pt thick horizontal lines

sd

sd

sd

in TeX-Code before the table or table float. The changed thickness is valid for all following
tables. To use the default value again, set \arrayrulewidth to 0.4 pt in TgX-Code behind
the table or table float.

To set the line thickness to 1.5 pt only for horizontal lines, like in Table 2.25, insert these
commands in TEX-Code before the table or table float:

\let\myHIline\hline

\renewcommand{\hline}
{\noalign{\global\arrayrulewidth 1.5pt}
\myHline\noalign{\global\arrayrulewidth 0.4pt}}

To return to the default line thickness, insert this command in TgX-Code behind the table
or table float:

\renewcommand{\hline}{\myHline}

To set the line thickness to 1.5 pt only for vertical lines, create the following column format
in the document preamble, according to the description in section 2.12.3:

\newcolumntype{V}{!{\vrule width 1.5pt}}
For Table 2.26 the I&TEX-argument

VeV

was used for the last column and

Ve

for the other columns.

2.12.5 Dashed Lines

You need to install the package arydshln to see the content of this section in the output.

35



2 Tables

Table 2.26: Table with 1.5 pt thick vertical lines

sd

sd

sd
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3 Floats

3.1 Introduction

A float is a block of text associated with some sort of label, which doesn’t have a fixed lo-
cation. It can “float” forward or backward a page or two, to wherever it fits best. Footnotes
and Margin Notes are also floats, because they can float to the next page when there are too
many notes at the page.

Floats allow a high quality layout. Images and tables can evenly be spread to the pages
to avoid white space and pages without text. As the floating often destroys the context
between the text and the image/table, every float can be referenced in the text. Floats are
therefore numbered. Referencing is described in section 3.4.

To insert a float, use the menu Insert> Float. This inserts the Caption inset, a box with a
label. The label will automatically be translated to the document language in the output.
Behind the label you can insert the caption text. The image or table is inserted above
or below the caption in a separate paragraph within the float. More about the caption
placement is described in section 3.8. To keep your LyX-document readable, you can open
and close the float box by left-clicking on the box label. A closed float box looks like this:

float-Figute. _ 5 oray button with a red label.

It is recommended to insert floats as a separate paragraph to avoid possible IATEX-errors
that can occur when the surrounding text is specially formatted.

Existing figures or tables can be put into a float by marking them and then pressing the
corresponding toolbar button for a new float.

3.2 Float Types

Besides figure and table floats that are described in section 1.2 and 2.5, respectively, LyX
offers the float types Algorithm and Text Wrap Float.

3.2.1 Algorithm Floats

This float type is inserted with the menu Insert> Floats > Algorithm. It is used for program
codes and descriptions of algorithms. A possible environment for algorithms is the LyX-
Code, described in LyX’s Userguide. Algorithm 3.1 is an example of an algorithm float
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Algorithm 3.1 Example Algorithm float
for I in 1..N loop
Sum:= Sum + A(I); /*commentx/
end loop

where -4 mm vertical space was added at the end of the float to have the bottom rule exactly
below the last text line.

The float label is not automatically translated into the document language. If your docu-
ment is not in English, you have to do this manually by adding the following line to the
document preamble:

\floatname{algorithm}{your name}

your name is the word “algorithm’ in your language.

Note: When the IATEX-package hyperref is used to link cross-references to floats in the
PDF-output, it must be loaded in the document preamble before the definition of
floats to be able to reference floats. As LyX sets the float definition for algorithm
floats automatically before the user editable part of the document preamble, you
need to insert the following preamble lines after the loading command of hyperref:

\newfloat{Xalgorithm}{tbp}{loa}
\floatname{Xalgorithm }{your name}
\newcommand{\theHalgorithm}{\theHXalgorithm}
\renewenvironment{algorithm}[1][tbp]
{\begin{Xalgorithm}[#1]}{\end{Xalgorithm}}

To insert the list of algorithms you can in this case not use the menu Insert > List/ TOC >
List of Algorithms but have to use this command in TgX-Code instead:
\listof{Xalgorithm}{List of Algorithms}

Algorithm floats are not by default numbered in the scheme “‘chapter.algorithm” like it is
the case for table and figure floats in many document-classes. To number algorithm floats
in the same scheme, add this command to your document preamble:

\numberwithin{algorithm}{chapter}

If you use the I&TgX-package hyperref, add this line instead after the definition of Xalgo-
rithm (the commands from above) to the preamble:

\numberwithin{Xalgorithm}{chapter}

To be able to use the command \numberwithin, set in the tab Math Options in the docu-
ment settings the option Use AMS math package.

3.2.2 Text Wrap Floats

This float type is used if you want to “wrap” text around a figure so that it only occupies
some fraction of the column width. It can be inserted using the menu
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Insert> Floats > Text Wrap Float if the IATEX-package floatflt is installed.! The width and
placement of the float is adjusted by right-clicking on the float box. Figure 3.1 is an exam-
ple text wrap float with a width of 40col%.> Some space was added under the caption to
separate it better from the surrounding text.

The IATEX-package floatflt also supports table wrap
floats, but they are not yet supported by LyX. If you
need this, read the documentation of floatflt [8].

Note: Text wrap float floats are fragile! E. g. having
a figure too close to the bottom of the page can mess
things up in the way that the float doesn’t appear in
Figure 3.1: This is a wrapped fig- the output or that it is placed over some other text.?

ure, and this is the brilliant caption In general:

that ngéBeﬁétaits should not be placed in paragraphs that run over a page break. That
means that wrap floats should better be inserted to the exact place when the document
is nearly finished and you are able to estimate where page breaks will appear.

* Wrap floats should either be placed in an own paragraph before the paragraph where
they should wrap into or within a paragraph.

* Wrap floats in consecutive paragraphs may cause troubles, so assure that there is a
text paragraph between them as separator.

* Wrap floats are not allowed in section headings or tables.

3.3 Float Numbering

Floats are usually numbered either independent from the sections the floats are in, or in the
scheme ‘“‘chapter.number” or “section.number”. This depends on the used document class.

To change the section independent numbering, you can use this command in the document
preamble:

\renewcommand{\thetable}{\roman{table}}

\thetable is the command that prints the table number, for figure floats, the command
would be \thefigure. The command \roman prints in the command above the table number
as small roman number.

To change the numbering scheme for example to “subsection.number”, use this command
in the preamble:

\numberwithin{table}{subsection}

To be able to use the command \numberwithin, set in the tab Math Options in the docu-
ment settings the option Use AMS math package.

Please also have a look at section 4.2.1 for the details and important notes about the num-
bering commands.

Installing a IATEX-package is explained it in the BIEX Configuration manual.
2 Available units are explained in A.

3The better solution is to use the IATEX-package wrapfig instead of floatflt, but it is currently not supported
by LyX. 39
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3.4 Referencing Floats

To reference a float, insert a label into its caption using the menu InsertrLabel or the

toolbar button [‘—@- A grey label box like this one: i 53-8 will be inserted and the
label window pops up asking for the label text. LyX offers as text the first words of the
caption with a prefix. The prefix depends on the float type, e. g. for figure floats the prefix
will be "fig:".

The label is used as anchor and name for the reference. You can refer to the label using

the menu Insert> Cross-reference or the toolbar button tﬂ A grey cross-reference box

. . Ref: sec:Contrih . . .
like this one: will be inserted and the cross-reference window appear

showing all labels of the document. If you have multiple LyX-documents opened, choose
the one you are working on from the drop-list at the top of the dialog. You can now sort
the labels alphabetically and then choose one. At the position of the cross-reference box
the float number will appear in the output.

It is recommended to use a protected space between the cross-reference name and its num-
ber to avoid line breaks between them. If a cross-reference refers to a non-existing label,
you will see two question marks in the output instead of the reference.

You can change labels at any time by clicking on the label box. References to the changed
label will automatically change its link to the new label text, so that you don’t need to take
care about this.

The button Go to Label in the cross-reference window sets the cursor before the referred
label. The button text changes then to Go Back and you can use it to set the cursor back to
the cross-reference. Right-clicking on a cross-reference box also sets the cursor before the
referenced label but without a possibility to go back.

3.4.1 Cross-Reference Formats

There are six varieties of cross-references:

<reference>: prints the float number, this is the default: 1.3

(<reference>): prints the float number within two parentheses, this is the style normally
used to reference formulas, especially when the reference name “Equation” is omit-
ted: (2.1)

<page>: prints the page number: Page 4
on page <page>: prints the text "on page" and the page number: on page 4

<reference> on page <page>: prints the float number, the text "on page", and the page
number: 1.3 on page 4
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Formatted reference: prints a self defined cross-reference format. Note: This feature is
only available when you have the I&TEX-package prettyref installed.

Note that the style <page> won’t print the page number if the label is on the previous, the
same, or the next page. You will e. g. see the text “on this page” instead.

The number and current page of the referred document part in the output, is automatically
calculated by IATEX. The varieties are adjusted in the field Format of the cross-reference
window, that appear when you click on the cross-reference box.

3.4.2 Referencing Subfigures

Currently referencing subfigures is not supported by LyX, so you have to use IATEX-
commands. The label is the created with the command

\label{fig: YourLabelName}

that is directly inserted into the subfigure caption field. To reference the label add this
command in TgX-Code

\ref{fig: YourLabelName}

to the position in your document where the reference should be placed. Here is a reference
to a subfigure: Subfigure 1.3(b).

3.4.3 Automatic Reference Naming

The I&TgX-package hyperref provides a very useful feature that cross-references automat-
ically include the name of the referenced floats (or text parts like sections). You save to
write e. g. the name “Figure” before every reference box. To get this automatic reference
naming, you have to load the I&TgX-package hyperref in the document preamble with

\usepackage[pdfborder={0 0 0}]{hyperref}
\AtBeginDocument{\renewcommand{\ref}[1]{\mbox{\autoref{#1}}}}

hyperref is used to link cross-references in the DVI- and PDF-output, this means that the
reader of your document will be able to click on a table of content (TOC) entry or on a
reference and he will be shown the referenced document part. hyperref also creates PDF-
bookmarks for every section of your document to make it easier for readers to navigate
through the document. This is also used in this document but when you have a look in the
document preamble you will find various options in the load command of hyperref. To
learn more about the hyperref package, we refer to its documentation [11].

Note: Automatic reference naming cannot be used when you use cross-references in the
Formatted reference style, described in section 3.4.1.

41



3 Floats

3.4.4 Reference Position

If you use hyperref to link cross-references in the output, you will see that clicking on an
image float reference jumps to the image label. The caption will be the first text part on the
screen, so that you cannot see the image without scrolling. This is because the reference
link anchor is placed at the position of the label. With the use of the package hypcap,
which is part of the I&TEX-package oberdiek, the link anchor is placed at the beginning of
a float. To use this feature for figure floats, load hypcap in the document preamble with
the line

\usepackage[figure]{hypcap}

You can also use hypcap for all floats but this isn’t recommended for stability reasons. For
more informations, have a look at hypcap’s manual [10].

Note: hypcap must be loaded after hyperref in the document preamble.

Note: hypcap has no effect for references to subfigures.

3.5 Float Placement

Right-clicking on a float-box opens a dialog where you can alter the placement options that
IXTEX uses for positioning the float.

The option Span columns is only useful for two-column documents: If you select it, the
float will span across both columns on the page instead of being confined to just one.

The option Rotate sideways is used to rotate floats, see section 3.6.

You can use one ore more of the following options in the float dialog to set the placement
for a particular float when you uncheck the option Use default placement:

Here if possible try to place the float on the position where it is inserted
Top of page try to place the float on the top of the current page
Bottom of page try to place the float on the bottom of the current page

Page of floats try to place the float on an own page

The order of the above option is always used by IAIEX. That means, if you use the default
placement, IATEX will first try out Here if possible, then Top of page, and then the others.
If you don’t use the default, I&TEX will try only the checked options but in the same order.
If none of the 4 placements are possible the procedure is internally repeated but it is tried
to put the float on the following page.

By default, each option has its own rules:

Top of page only floats occupying less than 70 % of the page can be placed at the top of a
page (\topfraction)
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Bottom of page: only floats occupying less than 30 % of the page can be placed at the
bottom of a page. (\bottomfraction)

Page of floats: only if more than 50 % of the page are occupied by floats, several floats
can be set together on a page. (\floatpagefraction)

If you don’t like these rules, you can ignore them by using the additional option Ig-
nore IATEX rules.

You can also redefine the rules with I&TgX-commands that are given in parentheses behind
the rules description above. To increase for example the often too small default of the
bottom-rule to 50 % of the page, add this line to your document preamble:

\renewcommand{\bottomfraction}{0.5}

Sometimes you might need, under all circumstances, a float to be placed exactly at the
position where it is inserted. For this case you can use the option Here definitely. Use
this option very rarely and only if the document is nearly ready to be printed. Because the
float is then no longer able to “float” when you change your document and this will often
destroy the page layout.

There are no placement options for text wrap floats, because they are always surrounded
by the text of a certain paragraph.

Sometimes you have the problem that a float is placed at the top of a page while its cor-
responding section starts at the middle of the page, so that the reader could think the float
is part of the previous section. To avoid this the I&I[EX-command \suppressfloats can be
used. It suppresses a given float placement for the page where it is inserted and can there-
fore be used to avoid that floats could be set before a section starts. To get this, add these
commands to your document preamble:

\let\mySection\section
\renewcommand{\section }{\suppressfloats[t]\mySection}

You can define the same for all section headings, like chapters and subsections. This
definition is not recommended to be used for small text parts like subsubsections because
IATEX may then have problems to find a suitable placement.

In some cases it is required to have all figures/tables at the end of the document. For this
purpose the I&TgX-package endfloat was developed. It puts all figure and table floats at
the end of the document into own sections. At the original float position a text hint like
“[Figure 3.2 about here.]” is inserted. The endfloat-package is loaded in the preamble with
the line

\usepackage[options]{endfloat}

There are various package options to format the created figure/table sections. For more
information we refer to the endfloat documentation [7].

Note: endfloat doesn’t provide an automatic translation for the text hint, you have to do
this manually, see section 4 in [7].
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Note: There is currently a bug in endfloat when the caption contains a German “B”. Use
in this case the command “\ss” in TgX-Code instead of “3”.

For more details about float placements, have a look at I£TEX books, [1, 2, 3].

3.6 Rotated Floats

Especially for wide tables you might have floats rotated. To rotate a whole float including
the caption, right-click on the float-box and use the option Rotate sideways.

Rotated floats are always placed on its own page (or column, when you have a two-column
document). They are rotated so that you can read them from the outside margin. To
force a certain rotation direction for all pages, you can add either the option figuresleft or
figuresright to the document class options.

Referencing rotated floats is the same like for normal floats, the caption format is also the
same: Table 3.1 is an example of a rotated table float.

Note: Not all DVI-viewers are able to display rotated floats.

3.7 Caption Formatting

The Caption environment is the default paragraph environment for Floats. On the LyX
screen captions appear as label, e. g. “Figure #:” followed by the caption text. “#” is the
actual reference number. By default the label and the number are in the same font as the
caption text and a colon follows the number to divide the label from the text. This caption
format is not suitable for all document formats.

To change the default caption format, load the IATEX-package caption in the document
preamble with this line:

\usepackage[format definition]{caption}

To have for example the label and the number in sans-serif bold font and the table captions
always above the table like in this document, use the following command:

\usepackage[labelfont={bf,sf}, tableposition=top]{caption}

You can also define different caption formats for the different float types. In this case load
the caption package without format specific options and define the different formats with
the help of the command

\captionsetup|[float type]{format definition}

in the document preamble. For example the caption formats of Figure 3.2 and Table 3.2
can be created using these commands in the document preamble:
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\usepackage[tableposition=top]{caption}

\captionsetup[figure]{labelfont={tt}, textfont=it, indention=1cm, %
labelsep=period}

\captionsetup[table]{labelfont={bf,sf}}

Note: The option tableposition=top has no effect when a koma-script document class is
used. In this case the document class option tablecaptionabove must be used.

For more information about the package caption we refer to its documentation [5, 6].
To change the label name from e.g. “Figure” to “Image” use this preamble command:
\renewcommand{\fnum @figure }{Image~\thefigure}

2

where \thefigure inserts the figure number and “~” creates a protected space.

If you are using a koma-script document class (article (koma-script), book (koma-script),
letter (koma-script), or report (koma-script) ), you can alternatively to the caption package
use koma-script’s built-in command \setkomafont. For example, to have the caption label
in bold, add this command to your document preamble:

\setkomafont{captionlabel }{\bfseries}

For more information about \setkomafont we refer to the koma-script documentation
[12, 13].

3.8 Caption Placement

The common caption placement rule is:

Figure: Caption is set below the figure
Table: Caption is set above the table

Having the caption above the table is unfortunately not supported in IATEX’s standard
classes. That means if you are using the document classes article, book, letter, or report
there will be no space between the caption and the table. To insert the needed space, add
the following option to the load command of the IATEX-package caption in your document
preamble*:

tableposition=top

If you are using a koma-script document class (article (koma-script), book (koma-script),
letter (koma-script), or report (koma-script) ), you can alternatively to the caption package
set the document class option tablecaptionabove.

It is also possible to set the caption beside a figure or table. To get this the I&TgX-package
sidecap has to be loaded in the document preamble with the line

4See section 3.7 for more information of the package caption.
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\usepackage[option]{sidecap}

If you set no option, the caption is placed on the side of the outer page margin — to the right
on odd pages, to the left on even pages. You can change the placement to inner margin
with the option innercaption. To force the placement always to the right or left, use the
option rightcaption or leftcaption, respectively.

To place in LyX the caption of a float on the side, it is necessary to add these commands to
the document preamble:

\newcommand{\TabBesBeg}{ %

\let\MyTable\table

\let\MyEndtable\endtable
\renewenvironment{table}{\begin{SCtable}}{\end{SCtable}}}

\newcommand{\TabBesEnd }{ %
\let\table\MyTable
\let\endtable\MyEndtable

\newcommand{\FigBesBeg}{ %

\let\MyFigure\figure

\let\MyEndfigure\endfigure
\renewenvironment{figure}{\begin{SCfigure}}{\end{SCfigure}}}

\newcommand{\FigBesEnd }{ %
\let\figure\MyFigure
\let\endfigure\MyEndfigure}

The commands allow you to redefine the floats so that the caption is set on the side. For
figure floats use the command

\FigBesBeg

in TeX-Code before the float. Behind the float insert the command
\FigBesEnd

in TgX-Code to get back to the original float definition.

For table floats use the corresponding commands

\TabBesBeg and \TabBesEnd

Figure 3.3 and Table 3.3 are examples where the caption is set beside.

You can see in the examples that the caption text appears at the top of the floats for table
floats and at the bottom for figure floats. To change this, you can use the command

\sidecaptionvpos{float type}{placement}
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in the document preamble or in TgX-Code before the float. The float type is either figure
or table, the placement can be “t” for top, “c” for center, or “b” for bottom. To have for
example the caption of figure floats vertically centered, use the command

\sidecaptionvpos{figure}{c}
This was used for Figure 3.4.

For more information about the package sidecap we refer to its documentation [17].

Note: The I&TgX-package hypcap, described in section 3.4.4, has no effect on floats with
the caption set beside.

3.9 Listings of Floats

Similar to the the table of contents where the sections of the document are listed, there are
listings for all float types, like the figures of the documents. You can insert them via the
Insertr> List / TOC sub menus.

The list entries are the float captions or its short title, the float number, and the page number
where they appear in the document.

You can find the list of figures and tables at the end of this document.
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Figure 3.2. This is an example figure caption that is longer than one line to show
the different caption format. Here a self-defined caption format is used.

Table 3.2: This is an example table caption that is longer than one line to show the different
caption format. Here the standard caption format for tables in this document is used.

Figure 3.3: This is a caption
beside a figure.

Table 3.3: This is
a caption beside a
table.

Figure 3.4: This is a verti-
cally centered caption beside a
figure.
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4.1 LyX Notes

Notes are inserted with the toolbar button

or the menu Insert>Note. There are five

types of notes:

LyX Note This note type is for internal notes that won’t appear in the output. Its note-box
looks like this:

Mote

This 15 text in a note box that doesn't appear in the cutput.

Comment This note also doesn’t appear in the output but it appears as I£I[EX-comment,
when you export the document to I&TEX via the menu File > Export > IATEX (pdflatex)
/ (plain). Its note-box looks like this:

Comanent | Thig iz text in a note box that only appears as comment in LaTe3{-files,

Greyed Out This note will appear in the output as grey text. Its note-box looks like this:

Creyed 0wt ' Thig iz text of a comment that appears in the output as grey text.

1

As you can see in the example, the first line of greyed out notes is a bit indented
and greyed out notes can have footnotes.

Framed This note will appear in the output as framed text. Its note-box looks like this:

Framed \Thiz 15 text in a note box that appears framed in the output.

This is text in a note box that appears framed in the output.

In contrary to framed boxes? the frame uses always the whole text width and the note
is set into its own paragraph.

IThis is an example footnote within a greyed out note.

2Framed boxes are described in section 5.3.
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Shaded This note will appear in the output with red background color. Its note box looks
like this:

In contrary to colored boxes® the note uses always the whole text width and the note
is set into its own paragraph.

When you use the toolbar button to insert notes, a LyX Note is inserted. You can switch
between the five note types by right-clicking on the note-box. If you want to turn existing
text into a note, mark it and click on the note toolbar button. To change a note to text, press
the backspace key when the cursor is in the first position of a note, or press the deletey key
when the cursor is in the very last position of the note, respectively.

You can change the text color of the greyed out notes in the preamble with the following
command:

\renewenvironment{lyxgreyedout}
{\textcolor{color \bgroup}{\egroup}

The available colors and the method to define own colors is explained in section 2.11.

Notes that appear in blue in this document are set using greyed out notes with blue text.

The text style of Framed and Shaded notes can be set in the Text Style dialog.

The default frame width for Framed notes is 0.4 pt; it can be changed by changing the
size \FrameRule. The default space between the note content and the frame is 9 pt; it can
be changed by changing the size \FrameSep. For example the frame appearance of the
following Framed note is set with the TgX-Code commands

\FrameRule 5pt \FrameSep 0.5cm

This is text in a Framed note.

For Shaded notes the default space between the note content and the note border is 3 pt; it
can be changed by changing the size \fboxsep.

3Colored boxes are described in section 5.7.
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The default background color red can be changed with the command \definecolor{shadebox}.
The scheme of the \definecolor command is explained in section 2.11%.

For example the appearance of the following Shaded note is set with the TgX-Code com-
mands

\fboxsep 0.5cm
\definecolor{shadecolor}{cmyk}{0.5,0,1,0.5}

This is yellow text in a Shaded note with darkgreen background.

4.2 Footnotes

Footnotes can be inserted using the toolbar button \; or the menu Insert> Footnote. You’ll

see then the following footnote-box: foot where you can enter the footnote text. If you
want to turn existing text into a footnote, mark it and click on the footnote toolbar button.
To change a footnote to text, press the Backspace key when the cursor is in the first position
of a footnote, or press the Delete key when the cursor is in the very last position of the
footnote, respectively.

Here is an example footnote:’

The footnote will appear in the output as a superscript number at the text position where
the footnote box is placed. The footnote text is placed at the bottom of the current page.
The footnote number is calculated by IXTEX, the numbers are consecutive. It depends on
your document-class, if the footnote number is reset for every chapter.

Footnotes can be referenced like floats: Insert a label into the footnote and cross-reference
this label in the text as described in section 3.4.
This is a cross-reference of Footnote 5.

To use footnotes within tables, you have to use minipages, see section 5.4. Footnotes within
longtables are described in section 2.6.1.

To create only a mark for a footnote, use the command \footnotemark[number] in TEX-
Code. This is used when you have the same annotation several times in a text but doesn’t
want to print the footnote text every time.

As you don’t know the number of the repeating footnote while you are writing the text,
you have to store its number. For the following footnote mark example, these commands
were inserted in TgX-Code behind Footnote 5 to store the footnote number:

“Note that \definecolor requires the ISTEX-package color in the preamble, see section 5.7.

>This is an example footnote.
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\newcounter{MyRepeatFoot}
\setcounter{ MyRepeatFoot}{\thefootnote}

The footnote mark was then created with this command:
\footnotemark[\theMyRepeatFoot]

Here is an example footnote mark:?

4.2.1 Footnote Numbering

To reset the footnote number back to 1 after each section, add this command to your docu-
ment preamble:

\@addtoreset{footnote}{section}

The following preamble command changes the footnote numbering style to small roman
numerals:

\renewcommand{\thefootnote}{\roman{footnote}}
This is a footnote with roman numbering:“!

To change the numbering style to capital roman numerals replace in the command above
\roman by \Roman. To “number” footnotes with capital or small Latin letters use \Alph
or \alph, respectively. To “number” footnotes with symbols use \fnsymbol.

Note: You can only number 26 footnotes with Latin letters, because this numbering is
limited to single letters.
Note: You can only number 9 footnotes with symbols.

To return to the default numbering style when you changed to another one, use \arabic
instead of \roman in the command above.

If you want to have footnotes numbered in the scheme “chapter.footnote”, add the follow-
ing command to your document preamble:

\numberwithin{footnote}{chapter}

To be able to use the command \numberwithin, set in the tab Math Options in the docu-
ment settings the option Use AMS math package.

This is another example footnote:*”

Note: \numberwithin always prints out the footnote number as arabic number; previous
redefinitions to get non-arabic numbers are overwritten.

So to get for example the scheme “chapter.\Roman{footnote}”, use this command instead
of \numberwithin:

\renewcommand{\thefootnote}{\thechapter.\Roman{footnote}}

ViThis is an example footnote with roman numbering.

47This is a footnote numbered in the scheme “chapter.footnote”.
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4.2.2 Footnote Placement

If you have several footnotes in one page, they appear without vertical space between them
at the bottom of the page. To make them better readable you can e. g. add 1.5 mm space
with the following preamble command:

\let\myFoot\footnote
\renewcommand{\footnote}[1]{\myFoot{#1\vspace{1.5mm}}}

In a two-column document the footnotes appear at the bottom of every column, see Fig-
ure 4.1. If the footnotes should only appear at the bottom of the right column, as in Fig-
ure 4.2, use the I&TEX-package ftnright with this command in the document preamble:

\usepackage{ftnright}

Das dpektrum wird tfourlertranstormiert.
Die Fouriertransformation wird verwendet,
um die iberlagerten Signale (Netzwerk,
Losungsmittel) zu trennen. Nachdem wir

Sei nun S unser normiertes Ausgangssignal
und P die Phasenverteilungsfunktion, so
ergibt sich die Beziehung

die Phasenverschiebung bestimmen konn-

S =Su(®) [~ Po.0e% a0 (2)

ohne Gradient
Normierungsbedingung

das Signal

die

wobel Sg
ist  und

'Fourier transformation
2Phase distribution function

ten, interessiert uns nun das Aussehen des
Ausgangssignals. Im Experiment haben wir
es mit sehr vielen Teilchen zu tun, so dass

3Fourier transformation
4Phase distribution function

1

Figure 4.1: Standard footnote placement in two-column documents.

In some scientific literature it is usual to collect the footnotes and print them in a separate
paragraph at the the end of a section, like in Figure 4.3. They are then so called “endnotes”.
To use endnotes instead of footnotes in your document, load the IATEX-package endnotes
with the document preamble lines

\usepackage{endnotes}
\let\footnote\endnote

To insert the collected footnotes, insert the command

\theendnotes

in TeX-Code at the the end of a section or chapter.

The paragraph heading for the endnotes isn’t automatically translated into the document

language, this must be done manually. The following preamble command translate the
default English name “Notes” to the German translation “Anmerkungen”:
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man iber alle Phasen integrieren muss.
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Figure 4.2: Footnote placement in two-column documents when the IATgX-package ft-
nright is used.

\renewcommand{\notesname }{ Anmerkungen}

The numbering of endnotes can be changed like the footnote numbering as described in
section 4.2.1; just replace the command \thefootnote by \theendnote. To reset the end-
note number use the command \@addtoreset as described in section 4.2.1 and replace the
command parameter footnote by endnote.

To create only a mark for an endnote, use the command \endnotemark[number] similar
to the command \Mfootnotemark, described in section 4.2.

Footnotes can also be placed in the page margin and the footnote text alignment can be
changed, see the I&TEX-package footmisc, [9] for more information about this.

man iiber alle Phasen integrieren muss.
Sei nun S unser normiertes Ausgangssignal
und P die Phasenverteilungsfunktion, so
ergibt sich die Beziehung

Notes

'Fourier transformation

S(t) = Sp(t) /oo P(¢, t)eid) d¢ (2) *Phase distribution function

3Fourier transformation

4Phase distribution function

Signal ohne Gradient
Normierungsbedingung
1 gilt. Nun dirfen

wobei Sy das
ist und die

J2 P(¢,t)do =

Figure 4.3: Endnotes — footnotes are printed in a separate paragraph at the end of sections
or chapters.
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This is a
rgin note in
the inner
margin.

4.3 Margin Notes

For various further footnote formatting issues have a look at IATgX-books, [1, 2, 3].

4.3 Margin Notes

Margin notes look and behave in LyX like footnotes. They are inserted via the menu

Insert>Marginal Note or the toolbar button %I A grey box with the red label “margin”
appears where you can enter the text of the margin note.

At the side is an example margin note.

Margin notes appear at the right side in single-sided documents. In double-sided docu-
ments they appear in the outer margin — left on even pages, right on odd pages. The text of
margin notes is aligned opposite to the outer margin — right-aligned when the note appears
in the left margin. The first line of the margin note is placed at the position of the text line
where it is inserted in the document.

To place the margin note in the inner margin, add the command
\reversemarginpar

in TgX-Code before a margin note. The new placement is valid for all following margin
notes.

Note: There is often not enough space in the inner margin so that the notes are not
correctly displayed in the output.

To return to the default placement insert the command
\normalmarginpar

in TgX-Code. Note: The command is ignored when it is within a paragraph where also the
command \reversemarginpar is inserted.

Similar to the case described in section 2.8.1, long words cannot be hyphenated when they
are the first word in a margin note. To avoid this, insert the command

\hspace{Opt}
in TeX-Code before the word.

Note: Margin notes can normally not be used inside tables, floats, and footnotes.

This restriction can be evaded by using the IATEX-package marginnote. By adding these
two lines to your document preamble, the command used by LyX for margin notes is
redefined to use the command provided by the marginnote-package:

\usepackage{marginnote}
\let\marginpar\marginnote
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This margin
note is shifted
up 1.5cm
from its
original
position.

The text of
this margin
note is
centered.

Attention!
This is a
margin note
with a defined
heading.

4 Notes

This is also used in this document because marginnote has another useful feature: You
can set a vertical offset for the note. This is often needed when too many margin notes are
too close together or for a better page layout. The offset is set in LyX as TgX-Code directly
behind the margin note in the scheme

[offset]

where the offset is a length with one of the units listed in Table A.1. A negative value shifts
the note up, a positive value shifts it down. For example the margin note beside this text
line is shifted up 1.5 cm with the TgX-Code-command “[-1.5cm]”

With marginnote you can also change the alignment of the text in the margin note. For
example the commands

\renewcommand*{\raggedleftmarginnote }{\centering}
\renewcommand*{\raggedrightmarginnote}{\centering}

set the alignment to centered. \raggedleftmarginnote denotes margin notes that appear at
the left side. The default is

\renewcommand*{\raggedleftmarginnote}{\raggedleft}
\renewcommand*{\raggedrightmarginnote }{\raggedright}

For the other features of marginnote we refer to its documentation [15].

You can adjust the layout of margin notes by changing its definition. To create for ex-
ample a header for all margin notes with the underlined, sans-serif, and bold header text
“Attention!”, add this to your document preamble:

\let\myMarginpar\marginpar
\renewcommand{\marginpar}[1]{\myMarginpar{ %
\hspace{Opt}\textsf{\textbf{\underbar{Attention!}}} %
\vspace{1.5mm}\\#1}}
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5 Boxes

5.1 Introduction

Boxes are used to format a block of text. Boxes can be used to write documents with
multiple languages, see section 5.4, to frame texts, see section 5.3, to prevent words to be
hyphenated, see section 5.6.1, to align text, see section 5.6.2, or to set the background color
of texts, see section 5.7.

By

Boxes can be inserted with the menu Insertt>Box or the toolbar button =+, A grey box

with the label Box (Minipage): Her: W REET] , will be inserted. The box type can be
specified by right-clicking on the box. The appearing box dialog offers the Inner Box types
Parbox and Minipage. The type Minipage is the default for new boxes and is explained in
section 5.4; the type Parbox is described in section 5.5.

Boxes aren’t numbered and can therefore not be referenced like floats or footnotes.
Note: Boxes must not be the item in an ltemize or Description environment.

Note: For an unknown reason you can only set the Inner Box type to None when you
use a framed box. Boxes without an Inner Box type and without frames are explained in
section 5.6.1.

5.2 Box Dialog

In the box dialog you can adjust the box geometry in the fields Width and Height. The
available units for the geometry are explained in Table A.1. The field Heigth offers the
following additional sizes:

Depth This is the plain text “height”. It ignores the total depth when there are multiple
text lines in the box:

Box

to 1 Depth
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Height This is the heigth of the text that is inside the box. A value of e. g. 2 for this size

will set the box heigth to 2 times the text height:

Total Height This is the Height + Depth:

Width This sets the width of the box as heigth:

Box height set to
2 Height

Box height set to
1 Total Height

Box
height set
to 1 Width

When you have chosen an Inner Box, the vertical box alignment can be:

Top This is an example text line.

This box
is top-
aligned.

This is an example text line.

This box

Middle This is an example text line. | is middle-

aligned.

This is an example text line.

Bottom This is an example text line. | aligned.

This box
1s bottom-

This is an example text line.

The horizontal box alignment can be set via LyX’s paragraph dialog when you set the box

into its own paragraph.

When you have chosen an Inner Box, the box content can be vertical aligned to:

top This is an example text line.

middle This is an example text line.
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5.3 Framed Boxes

This box
text is
bottom-
aligned.

bottom This is an example text line. This is an example text line.

This box

stretch This is an example text line. | textis [This is an example text line.

stretched.

To stretch the box content, it must consist of more than one paragraph. In the example
above every text line is in an own paragraph.

To align the box content horizontally you can use LyX’s paragraph dialog when you have
chosen an Inner Box.

This box

text is

stretched.

If you haven’t set an Inner Box, you can align the box content horizontally in the box
dialog.

’ This box text is horizontally stretched.

5.3 Framed Boxes
The frame style of the box can be specified in the box-dialog in the drop-down list Type.
The following frame types are possible:

Rectangular box This draws a rectangle frame around the box. The frame line thickness
has the size of \fboxrule. ’ Rectangular box

Oval box, thin This draws an oval frame around the box. The frame line thickness has the
size 0.4 pt. [ Oval box, thin ]

Oval box, thick This draws an oval frame around the box. The frame line thickness has
the size 0.8 pt. ( Oval box, thick ]
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Shadow box This draws a rectangle frame with a shadow around the box. The frame line
thickness has the size of \fboxrule, the shadow has a width of 4 pt. Shadow box

Double box This draws a double-line rectangle frame around the box. The line thickness
of the inner frame is 0.75 \fboxrule, the thickness of the outer frame is 1.5 \fboxrule.
The distance between the lines is 1.5 \fboxrule + 0.5 pt. ‘ Double box ‘

LyX’s box label will change to the used frame style when you set a frame. To be able to
use the different frame styles, the IXTgX-package fancybox must be installed.

The default value for the size \fboxrule is 0.4 pt. It can be changed with the following
command in TgX-Code to e. g. 2 pt:

\setlength{\fboxrule}{2pt}

Rectangular box with
\fboxrule =2 pt

The space between the frame and the box content is for all frame styles by default 3 pt. You
can change it by setting the length \fboxsep to another value. For example the command

\setlength{\fboxsep }{10pt}
sets the value to 10 pt, like for the following box:

Rectangular box with
\fboxsep = 10 pt

The diameter of the round corners of the oval boxes can be set with the command \corner-
size. The command

\cornersize*{1cm}
sets the diameter to 1 cm. The command
\cornersize{num}

sets the diameter to num x minimum(width and heigth of box). The default is \corner-
size{0.5}.

Oval box with
\cornersize=1.5cm

The size of the shadow can be adjusted by changing the length \shadowsize. It it set to 2 pt
for the following box by this command:

\setlength{\shadowsize}{2pt}
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Shadow box with
\shadowsize =2 pt

5.4 Minipages

Changed lengths and widths are valid for all boxes following the commands that change

them.

5.4 Minipages

Minipages are treated by IATEX as pages within pages and can therefore for example have

their own footnotes.

Minipages are useful when you write documents with different languages.

Below are two example minipages side by side. Their width is set to 45 col% and they are
separated by a horizontal fill, that was inserted via the menu Insert> Special Formatting >

Horizontal Fill.

Dies ist ein deutscher Text. Dies ist ein
deutscher Text. Dies ist ein deutscher
Text. Dies ist ein deutscher Text. Dies ist
ein deutscher Text. Dies ist ein deutscher
Text. Dies ist ein deutscher Text. Dies ist
ein deutscher Text. Dies ist ein deutscher
Text. Dies ist ein deutscher Text. Dies ist
ein deutscher Text. Dies ist ein deutscher
Text. Dies ist ein deutscher Text?. Dies
ist ein deutscher Text. Dies ist ein deut-
scher Text.

“Dies ist eine deutsche Fullnote.

This is an English Text. This is an En-
glish Text. This is an English Text. This
is an English Text. This is an English
Text. This is an English Text. This is
an English Text. This is an English Text.
This is an English Text. This is an En-
glish Text. This is an English Text. This
is an English Text. This is an English
Text. This is an English Text. This is an
English Text. This is an English Text.”
This is an English Text.

“This is an English footnote.

Another application for minipages are footnotes within tables. Due to a I&TEX restriction
footnotes within tables doesn’t appear at the bottom of the current page. But when you put
the table with the footnote to a minipage, the footnote will appear at its bottom, numbered
with Latin letters. The footnote number is reset to 1 in every minipage but not outside the
minipages.

12|34
The footnote of this table doesn’t appear: | a c |d
e|f| g|h
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112]3% 4
alb|c |d
e|f|lgl|h

“This is a footnote within a ta-
ble.

The document-wide paragraph settings are ignored within minipages. That means that
there will be no space between paragraphs in minipages although you set it to e. g. MedSkip
in the document settings.

Minipages can also be used to set a background color for text parts, see section 5.7.2.

Note: You cannot have floats or margin notes inside minipages but minipages can be used
inside tables, floats, and other boxes.

5.5 Parboxes

Parboxes are very similar to minipages with the difference that they cannot have footnotes.
The main difference to minipages is that minipages are in contrary to parboxes no real
boxes but I&TEX-environments.

This a text within a parbox.
This a text within a parbox.

This footnote won’t appear:>

5.6 Boxes for Words and Characters

5.6.1 Prevent Hyphenation
You can use a special kind of boxes to prevent words or text to be hyphenated.
Here is an example text:

This line is an example to show how you can prevent the hyphenation of “veryverylong-
word”.

To prevent the hyphenation of the word “veryverylongword”, add the command

\mbox{
in TgX-Code before the word. Behind the word insert a closing brace “}” in TgX-Code.
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This is the result:

This line is an example to show how you can prevent the hyphenation of “veryverylongword”.
You can alternatively set the command “\-*“ as TgX-Code directly before the word:

This line is an example to show how you can prevent the hyphenation of “veryverylongword”.

Of course the word now protrudes over the side margin. To avoid this, add via the menu
Insert> Special Formatting>Line Break (shortcut Ctrl-Return) a line break before the
word:

This line is an example to show how you can prevent the hyphenation of
“veryverylongword”.

5.6.2 Vertical Alignment

With the help of the command \raisebox you can align words, characters or other boxes
vertically to the surrounding text. \raisebox is used with the following scheme:
\raisebox{lift}[height][depth]{box content}

The lift can be a positive value to raise the box or a negative value to lower the box.

To align for example the word “preventing” so that the bottom of the “deepest” character

€C_ %

p’” is at the baseline, insert the command
\raisebox{\depth}{

in TeX-Code before the word. Behind the word insert a closing brace “}” in TgX-Code.
This is the result:

This is a text line with the word “‘Preventing” g raised word.

When you raise or lower characters in a line, the line distance will be spread:

This is a text line with the word “preventing” as lowered word.
“testing”
This is a text line with the word as raised word.

If you want to prevent this for a certain reason, set the box height to a zero value. For
example use

\raisebox{-\depth}[0Opt]{

This is a text line with the word “fggtagting” as lowered word.
This is a text line with the word as raised word.
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5.7 Colored Boxes

5.7.1 Color for Text

To color the background of text the text must be put into a so called “colorbox”. This re-
quires that the IATEX-package color is loaded in the document preamble with the command

\@ifundefined{textcolor}
{\usepackage{color}}{}

The package color will be loaded automatically by LyX when you color text’.
Colorboxes are created with the command \colorbox. This will be used with the following
scheme:

\colorbox{color}{box content}

The box content can also be a box and colorboxes can also be within other boxes.

The following colors are predefined:
black, blue, cyan, green, magenta, red, white, and yellow.
You can also define your own color as described in section 2.11.

To have e. g. a red background for a word, insert the command
\colorbox{red}{

before the word in TgX-Code. Behind the word insert a closing brace “}” in TgX-Code.
This is the result:

This is a line where the word _ has a red background.

If you would have the box frame in a different color, you can use the command \fcolorbox
with the following scheme:

\fcolorbox{frame color}{box color}{box content}

\fcolorbox is an extension to \colorbox. The frame thickness and the space between the
frame and the box content can be adjusted with the lengths \fboxrule and \fboxsep, re-
spectively, as described in section 5.3.

For the following example the command
\fcolorbox{cyan}{magenta}{
was used.

Here is an example where the frame line thickness was set to 1 mm:

3To avoid that it is loaded twice the command \@ifundefined is used.
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5.8 Rotated and Scaled Boxes

Of course you can also have colored text inside a colorbox:

This is colored text within a colored, framed box.

Note: Text in colorboxes cannot have line breaks. To color multiple text lines or para-
graphs, use a box inside a colorbox as described in the following.

5.7.2 Color for Paragraphs

To set the background color for more than one text line, put the text into a minipage. Before
the minipage insert the \colorbox command

\colorbox{color}{

in TgX-Code. Behind the minipage insert a closing brace “}” in TgX-Code.

This is text with background color. This is text with background color.

The text can have footnotes? and can include tables and figures.

a ! 3
b2l | >
1 § C

¢ Another example footnote

5.8 Rotated and Scaled Boxes

To use the the commands described in this section, the I&TEX-package graphicx needs to
be loaded in the document preamble with the command

\@ifundefined{rotatebox}
{\usepackage{graphicx}}{}

Note: Some DVI-viewers can’t display rotated or scaled material.

Note: Floats mustn’t be inside a rotated or scaled box.

5.8.1 Rotated Boxes

To rotate material, you can put it into a rotated box. Such a box is created using the
command \rotatebox in TgX-Code with the following scheme:

\rotatebox[rotation origin]{rotation angle}{box content}
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The rotation origin is specified in the form origin=position. The following positions are
possible: ¢ (center), [ (left), r (right), b (bottom), ¢ (top), and also expedient combinations
of the four base positions. For example /t means, that the rotation origin is at the top left
corner of the box. When no rotation origin is specified, the position / will be used. The
rotation angle is a number that can be negative that specifies the angle in degrees. The
rotation direction is counterclockwise.

In the following example the command \rotatebox[origin=c]{60}{ was inserted as TgX-
Code before the text “with rotated”; after the text the box was closed by a closing brace }
in TgX-Code.

This is a line

The box content can also be another box or an inline formula:

4,

2,
2,
Q 7
el
G, F
This is a line framed text \ and a formula.
or an image or table:
This is a line with a rotated image and table.
o |o
- | €

5.8.2 Scaled Boxes

To scale material the commands \scalebox and \resizebox can be used as TgX-Code.
\scalebox is used with the following scheme:
\scalebox{horizontal}[vertical]{box content}

Horizontal and vertical are the corresponding scaling factors. If no vertical scaling factor
is given, the horizontal factor will also be used as vertical one.

The command \scalebox{2}{Hello} creates for example a double size HeHO, com-
pared to the document text size.
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\scalebox{2}[1]{Hello} in contrary distorts the Hello.

If a the scaling factor is negative, the box content will be mirrored. Therefore the command
\scalebox{-1}[1]{Hello} can be used to create mirror writing: ollsH
\scalebox{1}[-1]{Hello} reflects the Helo at the base line.

Equivalent to \scalebox{-1}[1]{box content} there exists the command

\reflectbox{box content}.

The command \resizebox is used to scale the box to a defined width and height. The
command scheme is:

\resizebox{width}{height}{box content}

Is one of the two command arguments given as exclamation mark !, the size is set so that
the aspect ratio of the box content is kept.

The command \resizebox{2cm}{1cm}{Hello} produces: HeHO
The command \resizebox{2cm}{!}{Hello} produces: HGHO

Note: When arguments of \scalebox or \resizebox are set to zero, no IATX-errors occur
when exporting the document but the exported files can not or only partly be displayed.

The boxes can be combined in any order. E. g. the command
\rotatebox[origin=c]{-45}{\resizebox{2cm}{! }{\reflectbox{Hello}}}
produces:

7.
7.
%

Images, tables, and inline formulas are allowed as box content:

When the global formula style fleqn is used in the document*, also display formulas can
be scaled.

4When “fleqn” is added to the document class options.
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5.9 URLs (Uniform Resource Locators)

Links to web pages or email addresses can be inserted via the menu Insert>URL. The
appearing URL dialog has two fields; the URL field and the Name field for the URL de-
scription, which will be typeset as plain text immediately before the URL.

Here is an example URL: LyX’s homepage http://www.lyx.org

The option Generate hyperlink in the URL dialog does nothing. This relict will be removed
in the next LyX-version.

You cannot change the style of the link text. The text of the Name field will have the default
text style of the document while the text of the URL field will have the style “Typewriter”.

When you use the I&TgX-package hyperref to link cross-references in the output, URLs
will automatically become clickable hyperlinks in DVI and PDF-output.

Note: When you use the following characters: "%", "#", "", you have to write them with
a preceding backslash, e. g. “\#”. URLs must not end with a backslash.

To create real hyperlinks without the force to write the link location to the text, you can
use the command

\href{link location}{link text}
in TeX-Code. To get for example a link to LyX’s web page, write the command
\href{http://www.lyx.org}{

in TeX-Code. Insert after the command the link text “LyX’s homepage” as normal text
followed by a closing brace “}” in TgX-Code. This is the result: LyX’s homepage

To link to email addresses, add the prefix “mailto:” to the link location:
Email to lyx-docs mailing list.

Using \href instead of LyX’s URL box has the advantage that you can specify the text style
of the link text like for all other text parts. You can then set hyphenation points and forced
linebreaks to have long link text broken at the page margin. You are furthermore able to
change the text style for all URLSs in your document with an option in hyperref’s load
command and the restrictions mentioned above doesn’t apply for \href.
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6 External Stuff

With the menu Insert > File you can insert external material to your document. This can be:

LyX Document Another LyX document; its content is directly inserted to your document.

Plain Text A text document; every of its text lines is inserted to your document as own
paragraph.

Plain Text, Join Lines A text document; its text lines are inserted as they are. Empty text
lines creates a new paragraph in your document.

External Material Files in various formats.
Child Document LyX or I£IEX-documents.

6.1 External Material

The external material feature allows you to insert files to your document without converting
them previously to a format that can be read by the document output format because LyX
takes care of needed conversions. This is similar to images that can be inserted in various
image formats to LyX documents.

External material can be inserted via the External Material dialog that is accessible with
the menu Insert> File > External Material. Currently the following file types (Templates)
are allowed:

ChessDiagram This template supports chess position diagrams made with the program
XBoard.

Date This inserts the date in the form Day-Month-Year. This is a date inserted as external
material: 20-01-2008
The date is not shown within LyX, only in the output. There are two other methods
of inserting a date: Via menu Insert> Date and with the IATEX command \today as
TgX-Code. The different methods are compared in Table 6.1.

LilyPond This template is used for music notation typeset with the program
LilyPond.

Rasterlmage This can be used for bitmap images. Nearly all popular image formats are
supported. The image can be treated in the External material dialog like the images
that are usually included via the Graphics dialog as described in section 1.1. The
difference is that only raster images are allowed, that means that PDF and EPS-
images are not supported.

71


http://en.wikipedia.org/wiki/XBoard
http://en.wikipedia.org/wiki/LilyPond

6 External Stuff

XFig This template supports images created with the program Xfig.

Table 6.1: Comparison of the date input methods.

Document format | External Material>Date | Insert>Date command \today
LyX as inset box as date as TgX-Code inset box
ISTEX as date as date as command
DVI, PDF, PS as date as date as date

When you use the option Draft in the File tab of the External Material dialog, only the path
to the inserted file is shown in the output.

External material is displayed in LyX either as box like this: i, GaElEn

depending on the setting in the LyX View tab of the External Material dialog.

or as image,

The Customization manual explains how you can define your own templates.

6.2 Child Documents

Child documents are used when you have a long document consisting of several larger
parts or sections. For maintenance it is often useful and sometimes even required to split
the document in several files that can be revised separately. The different documents are
then the so called child documents and a master document connects them to print the full
document or parts of it.

Included documents are displayed in LyX as a box like this: Include: Customization. lyz
To include child documents to a master document use the menu Insert> File > Child Docu-
ments. A dialog pops up where you can choose between four include methods:

Include You can include LyX and ISTEX-documents. When you press the Load button in
the Child Document dialog, the included documents will be opened in LyX in a new
file tab so that you can modify it.

Here is a child document inserted using Include:
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6.2 Child Documents

6.2.1 External Subsection 1

This is a small dummy child document to show how files can be inserted to another docu-
ment.
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The section numbering includes the sections of the included files in the order they are
inserted in the master document. The included example document has for example a sub-
section that is numbered as subsection of this section. Labels of included documents can
be referenced: Subsection 6.2.1

The preamble of the child document is ignored, only the preamble of the master document
is used. Included documents are inserted starting on a new page and end with a pagebreak.

With the IAXTgX-command \includeonly you can specify which included child documents
are processed when the output is generated. This is useful when you are perhaps only
working on a certain chapter of your large document as this saves compiling time. \in-
cludeonly is inserted to the master document preamble. It takes a comma-separated list of
the filenames as argument, e.g.

\includeonly{chapterl,chapter5}

will only process the included files named “chapterl.lyx” (or “chapterl.tex””) and “chap-
terS.lyx” .

Note: When you have included a LyX- or I&TgX-file, you are warned when you ex-
port/view the document in case that the child document uses another document class than
the master document as this will lead to unexpected outputs.

Input This method is very similar to the Include method. The differences are:

* Input files don’t start with a new page and don’t end with a pagebreak.

* Input files can be previewed in LyX when Instant Preview is enabled in LyX’s
preferences under Look and feel > Graphics.

* The IATEX-command \includeonly cannot be used.

Here is a child document inserted using Input:

6.2.2 External Subsection 2

This is another small dummy child document to show how files can be inserted to a docu-
ment.

Verbatim With this method every text file can be included. The file is shown in the output
with its source code, no command used in the text is invoked. You can use the option
Mark spaces in output that displays the character “_,” for every space character in
the source code. The difference to the method via the menu Insert> File > Plain Text
is that the document content is not shown in LyX.

Here is a child document inserted as Verbatim:

This is a small dummy child text document to show how files can be ins

Here is a child document inserted as Verbatim using the Mark spaces in output option:
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This_is_a,small dummy,,child_text_document to_show_how_files_can_be_inserte

Note: As you can see in the examples above, the text of the documents included as verba-
tim is not broken at the end of the document lines.

Listings This type is described in chapter 7.

Note: Including the same document twice in a document using different methods could
cause IATgX-problems.
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7 Program Code Listings

To include and typeset program code you can use the Listings inset that can be inserted via
the menu Insert>Program Listing. The I&TEX-package listings provides a powerful and
flexible way to insert program source code to your document.

When right-clicking on a listings inset a dialog pops up where you can set the listings
format.

By default, a listing starts a new paragraph in the output. The placement option Inline listing
prints the listing inline like this: int a=5;

The option Float creates a listings float where you can specify the placement options “h”,
“1”, “b”, and “p” corresponding to the float placement options described in section 3.5. The
placement options can be mixed and are inserted without any separation, e. g. “htbp”. The
option “h” has sometimes no effect, but you don’t need to use the Float option in this case
as also non-float listings can have captions and be referenced.

You can add captions to listings with the menu Insert> Caption. Listings can be referenced
like floats: Listing 7.1

Listing 7.1: Example Listing float

# Example listing float

def func(param):
“this_,is_,a_python_function’
pass

When you have set a programming language in the listings dialog, the keywords of this
language will be recognized and specially typeset in the output. In the example listings the
Python keyword “def” is recognized and printed bold in the output.

Note: If you don’t get bold keywords when using typewriter fonts, your typewriter font
probably doesn’t provide a bold shape. In this case select a different one in the menu
Document > Settings > Fonts. (The fonts LuxiMono, BeraMono and Courier provide bold
shapes.)

In section Line numbering of the listings dialog you can specify the line numbering style.
You can insert a number to specify which lines are numbered to the field Step. When you
insert e.g. “3”, only every 3rd line will be numbered.

You can furthermore specify a range of lines, only these will then appear in the output. The
option Extended chars should be used when you use national characters like the German
umlauts in the listing.
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7 Program Code Listings

Here is an example listing with left line numbering, step “3”, language “Python”, options
“Extended chars” and “Space as Symbol”, range lines 3 - 8:

def_func (param):

>This_,is_,a_German_word:_Tschi}’
pass

def_func (param):
“this_,is_,a_python_function’

Note: Due to a bug in the listings package the line numbering is shifted by a line by every
previous listing. That’s the reason why the lines 2 and 5 are numbered in the above listing
and not the lines 3 and 6.

It is also possible to print lines from a file as listing. To do this, use the menu Insert>
File> Child Document and choose the type Listings.! In the child document dialog you can
specify the listing parameters in a text box. To show a list of all available parameters, type
in a question mark “?” in the text box.

To reference child document listings, write a label text into the corresponding field of the
child document dialog. The label can then be referenced using the menu Insert> Cross-
Reference.

Listing 7.2 is an example for a listing of a file; there the lines 10- 15 of this LyX file are
listed.

Listing 7.2: Lines 10 - 15 of this LyX file

% set fonts for nicer pdf view
\IfFileExists {Imodern. sty }
{\usepackage{Imodern}} % if it exists
{% if it exists not
\usepackage[scaled=0.92]{ helvet}

Global listings settings can be set in the Document > Settings > Text Layout dialog. To get
there a list of available options, type in a question mark “?” in the Listings settings field.

For more information about the listings package, we refer to its documentation [14].

I'The other child document types are described in section 6.2.
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A Units available in LyX

To understand the units described in this documentation, Table A.1 explains all units avail-

able in LyX.

Table A.1: Units

unit name/description
mm millimeter
cm centimeter
in inch
pt point (72.27 pt = 1 in)
pc pica (1 pc =12pt)
sp scaled point (65536 sp = 1 pt)
bp big point (72bp = 11in)
dd didot (1 dd =~ 0.376 mm)
cc cicero (1 cc=12dd)
Scale% % of original image width
text% % of text width
col% 9% of column width
page% % of paper width
line% % of line width
theight% % of text height
pheight% % of paper height
ex height of letter x in current font
em width of letter M in current font
mu math unit (1 mu = 1/18 em)

79



A Units available in LyX

80



B Output File Formats with Graphics

B.1 DVI

This file type has the extension “. dvi”. Itis called “device-independent” (DVI), because it
is completely portable; you can move them from one machine to another without needing
to do any sort of conversion. At the time when this file-format was developed, this was
no matter of course. DVIs are used for quick previews and as pre-stage for other output
formats, like PostScript.

Note: DVI-files doesn’t contain images, they will only be a linked. So don’t forget this,
if you move your .dvi file to another computer. This property can also slow down your
computer when you view the DVI. Because the DVI-viewer has to convert the image in the
background to make it visible when you scroll in the DVI. So we recommend to use PDF
for files with many images.

You can export your document to DVI by using the menu File > Export>DVI. You can view

your document as DVI via the View menu or by using the toolbar button .

B.2 PostScript

This file type has the extension *“.ps”. PostScript was developed by the company Adobe
as printer language. The file contains therefore commands that the printer uses to print
the file. PostScript can be seen as “programming language”; you can calculate with it and
draw diagrams and images!. Due to this ability, the files are often bigger than PDFs.

PostScript can only contain images in the format “Encapsulated PostScript” (EPS, file
extension “.eps”). As LyX allows you to use any known image format in your document,
it has to convert images in the background to EPS. If you have e.g 50 images in your
document, LyX has to do 50 conversions whenever you view or export your document.
This will slow down your work flow with LyX drastically. So if you plan to use PostScript,
you can insert your images directly as EPS to avoid this problem.

You can export your document to PostScript using the menu File > Export > Postscript. You
can view your document as PostScript via the View menu or by using the toolbar button

'If you are interested to learn more about this, have a look at the I&TEX-package PSTricks [16].
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B Output File Formats with Graphics
B.3 PDF

This file type has the extension “. pd£f”. The “Portable Document Format” (PDF) is de-
veloped by Adobe as derivative from PostScript. It is more compressed and it uses much
less commands than PostScript. As the name “portable” implies, it can be processed at any
computer system and the printed output looks exactly the same.

PDF can contain images in its own PDF format, in the format “Joint Photographic Experts
Group” (JPG, file extension “. jpg” or “. jpeg”), and in the format “Portable Network
Graphics” (PNG, file extension “.png”). Nevertheless you can use any other image for-
mat, because LyX converts them in the background to one of these formats. But as de-
scribed in the section about PostScript, the image conversion will slow down your work
flow. So it is recommended to use images in one of the three mentioned formats.

You can export your document to PDF via the menu File > Export in three different ways:

PDF (ps2pdf) This uses the program ps2pdf that creates a PDF from a PostScript-
version of your file. The PostScript-version is produced by the program dvips
which uses a DVI-version as intermediate step. So this export variant consist of
three conversions.

PDF (dvipdfm) This uses the program dvipdfm that converts your file in the background
to DVI and in a second step to PDF.

PDF (pdflatex) This uses the program pdftex that converts your file directly to PDF.

It is recommended to use PDF (pdflatex) because pdftex supports all features of actual
PDF-versions, is quick and works stable without problems. The program dvipdfm is not
under development and therefore a bit outdated.

You can view your document as PDF via the View menu or by using the toolbar button -}“
(that uses PDF (pdflatex)).

82



C Explanation of Equation (2.1)

The total width of n table cells Wiy, can be calculated to

Wiotn = n - (Wg, +2 - \tabeolsep) + (n+ 1) - \arrayrulewidth (C.1)

Where Wy, is the given width of all cells. \tabcolsep is the I&TEX-length between the cell
text and the cell border, its default value is 6 pt. \arrayrulewidth is the thickness of the
cell border line, the default is 0.4 pt.

Following equation (C.1), the total width of a multicolumn Wiy ¢ 1S
Wiotmult = Wemuit +2 - \tabcolsep + 2 - \arrayrulewidth (C.2)
By setting equation (C.1) and (C.2) equal we can calculate the needed given width Wy,

when n columns are spanned, so that each column has a total width of Wiy /7:

Wen = (Wamuic + (1 —n) - (2- \tabcolsep + \arrayrulewidth)) /n (C.3)
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